Arctic Cat Prowler Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 07family prowler idles good but at half thottle it just backfires and pops changed regulator and checked cdi box plug is black like the firing is off also adjusted the valves could it be the stator getting 14 volts any help it is drivibg me crazy
 

·
Banned
Joined
·
365 Posts
I have a 07family prowler idles good but at half thottle it just backfires and pops changed regulator and checked cdi box plug is black like the firing is off also adjusted the valves could it be the stator getting 14 volts any help it is drivibg me crazy
are you getting 14 volts with the prowler running.I get around 15 volts with mine running,doe's the word volt flash in the instrument panel.whats the volts on your battery with the prowler not running,have you looked at your plug,could also be your cdi box.check and see if your cdi box has a crack in it.
 

·
Registered
Joined
·
141 Posts
Have you noticed a loss of top end speed and more engine noise? When my cam and rockers went because of the oil pump gear failing I adjusted the valves and it sounded better but because of the wear on the rockers & cam it still ran bad. Check your oil pressure before you drive it too much more, or pull the head off and check the cam & rockers for wear.
 

·
Banned
Joined
·
365 Posts
Have you noticed a loss of top end speed and more engine noise? When my cam and rockers went because of the oil pump gear failing I adjusted the valves and it sounded better but because of the wear on the rockers & cam it still ran bad. Check your oil pressure before you drive it too much more, or pull the head off and check the cam & rockers for wear.
I agree, a oil gauge is great insurance.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top