Arctic Cat Prowler Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Got this thing brand new with 0 miles, it has 1350mi on it now and has a bad knocking sound in the motor.:wtf1: I changed the oil at 250 and 500 like they told me. It was running good then it just started to knock so i took it back to the house. Checked the oil and it was 2-1/2 quarts low but i never saw any oil leaking anyway. Does anybody have any idea of wat might be the prob. Or does anybody know if other people have had the same prob. Or if theres has been any recalls on this pos. thank you

my email is [email protected] thank you
 

·
Registered
Joined
·
108 Posts
I bet it has a knock, it only holds 2.6quarts.

I bought mine used and it was also low on oil with no visual leaks.

I checked everywhere and was changing all the fluids and checked the belt then I found the culprit.

I believe it was the seal for primary clutch shaft, tons of oil and debris around the seal and shaft.

You might want to pull your primary and take a look @ that seal.

Well I guess with a knock you are gonna pull it apart anyway.
Mine had low compression upon inspection I found all the plating on the cylinder was gone and huge ring gap's

Got the speedwerks 700 big bore. Way cheaper then going OEM.

Best of luck to ya!

AKcat are you in alaska? I have a parts motor and am in the fairbanks area. I got the motor blown up, Looks like it got hot, intake and exhaust scuffing. I believe the bottom end is ok.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Ya i live in soldotna. I took it to a shop today and found out that my wrist pin wore out and my piston was just floping around making a knock sound..... witch was also making it burn oil slowly.. they sai all my seals looked fine.
About a year ago i cracked my heilex in my primary clutch. The cat shop said they havent heard of that happening to anybody. Do u know anything bout that?
 

·
Registered
Joined
·
1 Posts
chiefdave1

i have a new 2010 700 it also has a knock in it with only 18 hours and 48 mi.oil was changed at 10 hours and i have the cowl off so i can check it daily.has anyone used any thing to the bottom of the cowl to cut down on the noise from the motor and heat coming up into the cab.also at low speed in any gear it jerks back and forth violently.i am really unhappy with this machine.
 

·
Registered
Joined
·
54 Posts
I used Dynomat also. It did help some, but it is still loud in my cab. My next move is wrapping the exhaust. I got my dynomat at amazon.com. They had free shipping to Alaska, which is a huge plus living up here.
 

·
Registered
Joined
·
108 Posts
I used Dynomat also. It did help some, but it is still loud in my cab. My next move is wrapping the exhaust. I got my dynomat at amazon.com. They had free shipping to Alaska, which is a huge plus living up here.
Wish I knew that b4 I bought my dynomat.
I got it off ebay and was charged 35.00 for shipping to alaska.

As far as wrapping the exhaust....
I thought about it and even bought the wrap then thought better of it.

When I go through water my exhaust steams up the cab for a moment from the header pipe dipping down so low.

And I know from having my mud drag truck exhaust wrapped that when it gets wet it steams for quite a while till all the wrap is dried out and it also has a terrible odor.

With all the water crossings up here in alaska it will be even worse with the steam.

just my thoughts.
Napa carries the wrap. If you do do it be sure to keep me posted please.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top