Arctic Cat Prowler Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Thanks for having me. I’m going to try and make this a good thread someone can use for troubleshooting reference in the future. Complete with an actually conclusion (like so many threads are missing).

I just picked up a 2008 prowler. Very nice machine. Great shape with about 290 hours and 1900 miles. Bought it non running. Took it on as a project. I’m cheap. So, I usually buy broken then fix.

It’s not running because it doesn’t have spark. I was hoping for something simple, but, I don’t think I’m going to get that lucky. Initial signs are pointing towards flywheel magnets or stator or CDI. All of these are expensive and suck. But, prior to tearing into the motor, I want to be damn sure.

I downloaded the service manual and will spend a little more time reviewing later. But, I do better figuring stuff out and using the manual for reference. Struggling to find a wiring diagram as well. But, was hoping there might be someone here that can help.

Key works and motor cranks. Just no spark. I put a test light on the white/blue wire going to the ignition coil and it’s not lighting while cranking. So, not getting signal to fire. Ground is good. I have continuity from the CDI harness plug to the coil. So, the pathway exists. The CDI is getting power.

I’m trying to figure out how to test pulse from the stator/flywheel. Can I hook a test light upto ground and probe a harness while cranking to verify the flywheel magnets are good?

It’s not a fuse. They are good. I haven’t checked diodes yet. Not sure how. And not sure what they are for exactly.

Thanks in advance.
 
1 - 2 of 2 Posts
Top