Arctic Cat Prowler Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys:

After washing my XT the other day the gauge cluster lights up, but no data at all appears nor does the speedo work. I tried disconnecting the battery, letting it dry out, checked all the fuses, etc but it appears to be just broken.

I will probably get another one, but to install do I need to take the whole dash off to get behind it? It seems to have some plastic bracket behind it preventing it from coming out or going in easily. Any help you guys can provide would be awesome.

Thanx guys...

Larry C
 

·
Premium Member
Joined
·
584 Posts
The manual says you have to remove the dash but I have gotten to the retaining nut by taking out the under hood storage box and just taking out the center upper and end dash retaining screws.
 

·
Banned
Joined
·
21 Posts
Hey guys:

After washing my XT the other day the gauge cluster lights up, but no data at all appears nor does the speedo work. I tried disconnecting the battery, letting it dry out, checked all the fuses, etc but it appears to be just broken.

I will probably get another one, but to install do I need to take the whole dash off to get behind it? It seems to have some plastic bracket behind it preventing it from coming out or going in easily. Any help you guys can provide would be awesome.

Thanx guys...

Larry C
You can do it without taking the whole dash out.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top