Arctic Cat Prowler Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I just got this prowler as a new left over, I added a kenwood 50W cd player and 3 speakers. I run the stereo for about 10 mins and the protection light comes on and shuts the stereo down, I have checked the wires and changed the stereo out and it still does it. can any one give me an idea of what else to do? I am wondering if something on the Prowler is wrong. Any help would be great
 

·
Registered
Joined
·
1 Posts
I just got this prowler as a new left over, I added a kenwood 50W cd player and 3 speakers. I run the stereo for about 10 mins and the protection light comes on and shuts the stereo down, I have checked the wires and changed the stereo out and it still does it. can any one give me an idea of what else to do? I am wondering if something on the Prowler is wrong. Any help would be great
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
stereo fixed! trans broke! WTF

sorry I haven't posted any reply's to this I had a job change and didn't have the time to be on line much. I ran the speaker wires thru the motor compartment and I had one get against the exhaust and short it. My big problem now is that the trans went out and I cracked the pan so I am in need of a full set of cases and pan or complete engine. I have to say that I am very disappointed in the quality of the Arctic cat machines. I ride with a good size group with a mixture of machines and those guy hammer their stuff with out regard, and have no issue! I drive mine on mostly trails and avoid mud and still it is always breaking! I am thinking once this motor is replaced or back together this thing is going. I like the new can am stuff it seems to be top quality. If any one has a motor or cases for a 2010 1000 xtz please let me know! thanks for all the help
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top