Arctic Cat Prowler Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi everyone,

I am new here and would like to say hello to all.... I also have a problem with my Prowler that I hope someone may be able to help me get a handle on.

I have a 2007 Prowler 650 with about 600 miles on it. The other day as I was riding the dash started flashing and the speedometer stopped working. The digital part or the dash goes off and then seems if it is trying to reset and does so for a second and then it flashes off again. Someone suggested a loose wire, but the flashing occurs on a regular interval ( every 2 seconds or so ) and then resets again and again. The machine does seem to run fine, but I am trying to figure out what is wrong.. Does anyone have any ideas?

Thanks,
Larry
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
same as mine... I couldn't get it fixed so at some point I have to take it to the dealer I guess... It runs fine, so I have been running it the way it is.. sorry I couldn't help
 

·
Registered
Joined
·
1 Posts
There is a red wire that supplys constant power to the dash that is causing your problem. It is the same wire that the accessory plugs are on. Should be red or red/white. cant remember. but if you get constant power to this wire it should fix your problem or it just has a loose connection. Sometimes if people put dioelectric greese in the dash connection it will force the pin loose. You can take the connection apart and squeeze the connector to make a better connection.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top