Arctic Cat Prowler Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2009 Prowler 700 xtx and until this point it has been a great machine with only minor issues. Recently my prowler was slow to start. It cranked and cranked until it finally started. Once it ran for a few moments, I turned it off and it started back fine. So I left off on a ride and seemed to be doing fine and it randomly bogged down and shut off. I could crank it and it wouldn't start back! I pulled the fuel relay under the seat and put it back it and it started back up and i luckily got it home. Before this little incident I had recently replaced the battery because it showed the "volt" message on the LCD pod. After that I had to take the relay from the neutral safety switch out and put it in place of the ignition relay because it had gone bad. (It wouldn't start when I turned they key over and when it did start as I pushed the brake pedal it would die. It also drained the battery when i put it back in the neutral relay spot so i know the relay was bad.) If any has any idea what is causing this problem please chime in. Could it just simply be the relay or maybe another weak battery? The battery shows 12v on my multimeter and shows 14.5 or so when running so I'm assuming it has nothing to do with the charging system. Also, when i push the brake pedal you can here and feel a clicking from the fuse panel under the seat if you have the seat removed and place your hand on the relays. Thanks guys.
 

·
Registered
Joined
·
710 Posts
Been trying to duplicate the relay clicking on mine. The relay allows starting in any gear. I agree with Diesel Racer on his thinking. Do you have a wiring diagram? I'll look at one, and see what all is connected through the relay/start circuit.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top