Arctic Cat Prowler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Bought it new a couple of weeks ago. When I put on thye breaks hard I get a loud grinding sound. Like gears that won't mesh. Much more distinct if on pavement. I've dropped part of the skid plate and gone thru the front end quickly. Nothing I can see. Any thoughts:wtf1:
 

·
Registered
Joined
·
17 Posts
Welcome to the prowler... I would have thought they would of addressed this problem by now. It more than likely is the rear brake chattering. I have a 07 and the local arctic cat dealer charged me $14 for two little springs that they said would cure the problem and it did not. I have heard people say the rotor on the 09 is better but I guess not. I am ordering a new rotor from EBC and new pads I will let you know if it works. I checked my front end also it sounds like gears grinding but more than likely it is the brake. If it is still under warranty I would take it back and show them the problem. Good Luck
 

·
Registered
Joined
·
17 Posts
Odd, that problem was addressed for 09 and the new rotor and pads that Cat has put on have cured the problem. None of my customers with 09 have complained, but most the 09s I've sold are 700s and 1000s, only 1 550, but it should be the same as the 700. In the past that was typical for a prowler to do.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Thanks man! Must admit, so far I am not

impressed with this machine. I thought I did due delligence before laying down $$$. Acceleration is sloooow for efi, FORGET about steering if diff. is locked, much noiser than the Rhino's I've ridden in. Well, it's like an ugly baby, I got to keep it.

It is under warranty, so back to dealer. Stay in touch, as will I
 
1 - 4 of 4 Posts
Top