Arctic Cat Prowler Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all! I have a 2010 Prowler 1000 that I bought. It had engine issues so I sent it to PSN (Powersportsnation) and they rebuilt it and tested. I installed it and I could not get it to start. It grinds but will not turn over. It sounds like it wants to. I have replaced the spark plugs twice, cleaned the fuel injectors, I do have a spark on both plugs and it is getting gas thru the injectors. I cleaned the throttle body and I did have to adjust the TBS. Any suggestions???
Thanks!
 

·
Registered
Joined
·
3 Posts
I am confused. What does "It grinds but will not turn over" mean? Is this a crank/no start condition?

Is it getting fuel? Is it getting spark? If yes, then timing is off. Fuel and spark are not synced with TDC on compression stroke. I'd call the rebuilder and make sure they actually ran it on a stand.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi, sorry for the confusion. I meant crank. Yes I have fuel and I do have spark. I did replace the front spark boot which had a bad connection. After doing so, I was getting white smoke coming out of the foam intake filter located behind the drivers seat. Would this mean the timing is off 180 degrees possibly or I wonder if they had the engine reversed? By that I mean if they had the front cylinder as the rear cylinder and visa versa.
 

Attachments

·
Registered
Joined
·
3 Posts
The white smoke is coming out while the engine is cranking but it still won't start?

I would see if there is a way to check timing. Make sure the camshaft/valvetrain is synced with the crankshaft. And that the timing chain was installed correctly.

I'd call the rebuilder too. What was wrong with it that it needed to be rebuilt?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top