Arctic Cat Prowler Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I bought my 2012 xtz used with 60ish hours on it. It had motomonster 30" tires and he said it had airdam stage 1 work on it and that the dealer did the work for him. I had my head up my rearend this weekend and smoked my belt and have pulled everything apart and am looking it over. I am trying to verify what has been done and sent e-mail through airdams website but thought I would ask here also. Does anyone know what color rollers come stock in the secondary? These are a red/orange color and the spring is set on B-3. I am trying to see if anything has been done to the secondary also.
Also looking for opinions on what belt to run.
Thanks
Frank
 

·
Premium Member
Joined
·
584 Posts
I bought my 2012 xtz used with 60ish hours on it. It had motomonster 30" tires and he said it had airdam stage 1 work on it and that the dealer did the work for him. I had my head up my rearend this weekend and smoked my belt and have pulled everything apart and am looking it over. I am trying to verify what has been done and sent e-mail through airdams website but thought I would ask here also. Does anyone know what color rollers come stock in the secondary? These are a red/orange color and the spring is set on B-3. I am trying to see if anything has been done to the secondary also.
Also looking for opinions on what belt to run.
Thanks
Frank
If they are red they are 19 gram rollers Is the fixed plate(the gold colored plate cut and welded in spots?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Yes the fixed plate has been cut and welded but there is very little change in pitch. There are also some initials in blue sharpie on there. See pic below.
Thanks on the roller weight. Is that a good middle of the road weight? If I am understanding the way the rollers work on the primary, I don't want to go to light get my rpm's up too quick.
Thanks for the help
Frank


 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Showed 62 on my phone with a compass/gps app so not sure how accurate that is. Not sure what the rpm was at the time either. I am not complaining at all on the setup, I feel like it runs great. I am just trying to look at everything, learn about it and verifying what I was told when I bought it.
Any idea what the factory setting is on the secondary is. This one is set on B3
Thanks again, hope I am not being a pain. Just trying to learn about my setup.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top