Arctic Cat Prowler Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
After I ride I can smell antifreeze from between the seats, not bad. There are no leaks or drips and the engine is dry. Is this normal or should I be concerned? 50 miles on motor. It starts and runs great.
 

·
Registered
Joined
·
54 Posts
The antifreeze is most likely comeing out of the overflow hose on the antifreeze reserve bottle. When you ride it sprays on you firewall and you smell it in the cab. That is what mine always did and I know other people that have the same problem. One of them told me about it.
 

·
Registered
Joined
·
1 Posts
Sorry guys for the bad news but if you are blowing antifreeze out of the overflow tank you most likely have a blown head gasket.

Try a leak-down test and see if you are pushing antifreeze out the radiator, if so problem confirmed.

I just got done replacing my head gasket. It sucks that the dealership is the only place to get a replacement, not to mention that there aren't any upgraded gaskets.
 

·
Registered
Joined
·
54 Posts
I had the same problem. My head gasket was blown, but I did not want to ruin stelerman's day since he said he only had 50 miles on it. I had to send my engine into Anchorage to get it done. Then after I received the engine back it would not run. I just sent the engine into Anchorage again. I have to pay for the freight both ways both times. Arctic Cat warranty says right in the book it does not cover travel. My machine has been down since May.
 

·
Registered
Joined
·
128 Posts
Next time you smell it go up to your reservoir bottle and see if its boiling off from the top of radiator cap vent tube down to your reservoir bottle then it it will boil out of the bottle vent tube and blow either the hot air or both fluid and air, if not the problem then look down on the driver side of the motor at the water pump and see if fluid is seeping down case towards oil filter, it could either be oil or antifreeze or both blowing by the pumps O ring seal, and if that's still not the case then look and see if you have a little steam out the exhaust
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
There is a little drip right under the water pump, I retightened the water pump bolts. They seemed a little loose. Could that be the only problem? Atleast it is not a head gasket.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
I found a tiny leak in back on top of the water pump, there is a tiny hole that a very tiny bit of coolant is dripping. Any Idea what that could be?
 

·
Registered
Joined
·
128 Posts
Same thing on mine I was loosing oil, I think there is 2 O rings one side for coolant other for oil if either one goes it comes out the hole like a water pump on a car, I was glad to figure out were the oil was going though. I still wafting to here what's up with mine
 

·
Registered
Joined
·
4 Posts
My antifreeze is leaking into the engine. I tkinking it is the head gasket. I dont see any drips. The radiator was full, I drove 2 miles and then checked it and could not see any antifreeze.
 
1 - 12 of 12 Posts
Top