Arctic Cat Prowler Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
first im a new to forum.i have had nothing but problems with my 2009 xtz from day 1.first it was little things like bolts breaking holding the fuel tank down,bolts holding air box above motor and bolts holding cooling line in place on the bottom of bike. second it was the overheating issue,then when u put it in neutral or low the led on dash showed Eand had no power .then i had noise in drive train between 10 & 20MPH and oil leaking from rear driveshaft seal . this was caued by a gear in transmission.now 100miles later the gear in transmission is doing the same thing and rear seal leaking again. all of this and only have 390 miles on bike.all has been coverd under warrenty.im just thinking what happens when warrenty runs out? has anyone else has issues with gears in tranny?oh by the way user name has nothing to do drive lol
 

·
Registered
Joined
·
19 Posts
I had right rear axle seal leaking was fixed under warranty when it gets out of warranty you can remove axle when seals go to leaking an remove the dust covers that are on the axles this causing the seals to get dirt/mud packed in I have a 650h1 that axle seals would leak I replaced 3 or 4 seals then I removed the dust cover an no other seal leakage all other atv's have no dust covers on there axles
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
the only seal i have problem with is rear driveshaft seal,but good to know about dust covers on axle.has anyone heard of gears in transmission wearing out or chipping? this is second time i had metal in the motor from this.
 
1 - 3 of 3 Posts
Top